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Getting started

This supplement to A Guide to Quark Publishing Platform describes the functionality

that the Office Adapter for Quark Publishing Platform® adds to Microsoft® Word,

Excel, PowerPoint and Visio.

Using these plugins, a user can:

store all Word, Excel, PowerPoint and Visio documents on Quark Publishing•

Platform using version control.

use a Quark Publishing Platform workflow to assign status and route•

Microsoft Word, Excel, PowerPoint and Visio digital assets.

create new Word, Excel, PowerPoint and Visio files from existing files or•

templates checked-in to the Quark Publishing Platform server.

create components from existing local Excel files and check in the•

components to the server.

insert components from the Quark Publishing Platform server in PowerPoint•

slides.

About Quark Publishing Platform

Quark Publishing Platform is a highly configurable solution for complete,

automated, end-to-end multichannel publishing. Quark Publishing Platform is

purpose-built to support end-to-end publishing needs, from complete manual

publishing systems to highly automated workflows.

Platform consists of a set of core modules that can be combined in various ways and

integrated with third-party systems to accommodate almost any workflow. Its

capabilities can be described in terms of content creation, management, publishing,

and delivery.

Create

Quark Publishing Platform lets you:

design professional templates for different publications.•

author structured content in the familiar Microsoft Word environment.•

integrate content from databases with other forms of content.•
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utilize multimedia content such as video, audio, images, and slideshows.•

Manage

Quark Publishing Platform provides:

workflow and collaboration tools.•

task and update notifications.•

component management.•

automated checks.•

version control.•

Publish

With Quark Publishing Platform, you can:

automatically assemble components of various types from various sources•

into sophisticated layouts.

automatically publish layouts in a variety of formats for a variety of devices.•

Deliver 

The automation features built into Quark Publishing Platform make it easy for you

to deliver content to your content consumers in both public and secure

environments.
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System requirements

The Office Adapters for Quark Publishing Platform require the following minimum

hardware configuration:

Processor: Intel Core i5, 2.5 Ghz (Intel Core i7, 3.4 Ghz recommended)•

8 GB of RAM (16 GB recommended) •

10 GB of available hard disk space •

Display with 1024 x 768 or higher resolution monitor •

Peripherals suitable for Microsoft® Office authoring •

DVD-ROM drive for installation from DVD (not required for installation•

from download)

The Office Adapters for Quark Publishing Platform require the following minimum

software configuration:

Windows 7® 32-bit (Enterprise, Professional or Ultimate) •

Windows 7® 64-bit (Enterprise, Professional or Ultimate) •

Windows 8® 32-bit •

Windows 8® 64-bit •

Windows 8.1® 32-bit •

Windows 8.1® 64-bit •

Windows 10® 32-bit •

Windows 10® 64-bit•

The Office Adapters for Quark Publishing Platform require one of the following

versions of Microsoft® Office:

Microsoft Office 2010 32 bit, Professional Edition. •

Microsoft Office 2013 32 bit, Professional Edition (Build 4849.1000 or later). •

Microsoft Office 2016 32/64 bit, Professional Edition (Deferred Channel:•

Version 1602, Build 6741.2071. Released on September 13, 2016).

Microsoft Office 365 (2013 and 2016) 32/64-bit•

Office Adapters for Quark Publishing Platform - Visio only supports Microsoft Visio
2013 and 2016.In addition, the following components are required for installation:
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Microsoft .NET Framework 4.7 or later. It is available for download at•

Microsoft’s Download Center: https://www.microsoft.com/en-

us/download/details.aspx?id=55167 

Once the required installation of Office is complete, you may install the Office

Adapters for Quark Publishing Platform.
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Installing the Office Adapters for
Quark Publishing Platform

Installing the Office Adapters for Quark Publishing Platform is a straightforward

process. The installation wizard will guide you through each step of the process.

These adapters can either be installed using a standard installer that installs all the

selected adapters in one go, or using the ClickOnce installation method that can be

run from your Quark Publishing Platform landing page. The ClickOnce installation

method has the added advantage of allowing updates to be managed and pushed to

the user by the server administrator, ensuring that all users use the same version of

the adapter.

Before you begin to install the Office Adapters for Quark Publishing Platform, be

certain that all required software including Microsoft Office have already been

installed. Also, run Office Updates at Microsoft.com to ensure the latest version is

installed. Close all running instances of Microsoft Office.

ClickOnce Installation

To install the Office Adapter for Quark Publishing Platform using the ClickOnce

installer:

Ensure that you have internet access. If any of the common Microsoft1.

libraries are not installed on your system, the installation process attempts

to download them.

If previous versions of the Office Adapter for Quark Publishing Platform have been
installed from the same ClickOnce location, the Office application will auto update

on launch.

If previous versions of the Office Adapter for Quark Publishing Platform have been
installed from a location other than the current ClickOnce location, use Control

Panel to uninstall all previous versions.

Open the Quark Publishing Platform installation landing page in the2.

browser.

This section on the Quark Publishing Platform landing page will only be available if
Platform Adapters for Microsoft Office components have been configured for web

sharing. For further information on setting up the Platform Adapters for Microsoft

Office components for web sharing, see the Quark Publishing Platform System

Administration Guide.
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Select the Microsoft Office product for which you wish to install the3.

Platform Adapter

Click Download and Install.4.

Click Accept and Install to accept the terms of the license agreement.5.

Double-click the setup.exe file and follow the instructions on the screen.6.

Office Adapters for Quark Publishing Platform have been successfully

installed.

This installation method will only install the Platform Adapter for the selected
Office product. The installation needs to be repeated for each product that requires

the adapter.

Updates to the installed version of the adapters will be installed automatically on
launch.

Standard Installation

To install the Office Adapter for Quark Publishing Platform using the Windows

installer:

From the installation media, double-click the setup.exe file and follow the•

instructions on the screen. Office Adapters for Quark Publishing Platform

have been successfully installed.

If previous versions of the Office Adapter for Quark Publishing Platform have been
installed, use Control Panel to uninstall all previous versions and patches.

Updates for each of the adapters need to be installed manually.
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System setup and preferences

The System Setup and Preferences section provides details on connecting to the

repository and specifying user preferences.

Some preferences are not modifiable when a server connection is currently
established. In that case, close all open documents and then try again.

Logging on to the repository

To use repository features such as Check In (Save) or Check Out (Open), you must

be logged on. Set your log on information so that the system can automatically log

you on.

If you do not have the log on information, please contact your system

administrator.

To specify log on information:

Choose File > Open > Quark Publishing Platform > Preferences.1

Click the Connection Settings tab.2

Specify the repository log on information provided by your system administrator.3
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If you do not specify log on information, then the credentials of the user that is
logged on to the machine are used.

Click + to add a connection name.4

If you have edited any of the connection settings, Click the Save icon to save the5
settings.

Click OK.6

You can now save multiple server settings by choosing +, entering a new name for
the settings, editing the existing values and clicking the Save button. Unwanted

settings can be removed using the Delete button.

You can select the required server from the Name drop-down list.

Your log on information is set.

Platform Adapter for Microsoft Office preferences

You can use the Preferences tab of the File menu (File > Preferences) to set your

Quark Publishing Platform Adapter for Microsoft Office preferences. 

All other Quark Publishing Platform preferences are stored on the Quark Publishing

Platform server. 

The General tab
The General tab of the Preferences dialog box allows you to specify the local folder

that documents you check out will be located in. The Deletion Options drop-down

menu displays the following deletion options:
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Ask Before Deleting: to display an alert each time you attempt to delete a•

checked-out document. 

Never Allow Deletion: to protect against deleting checked-out documents.•

Delete Without Warning: to delete checked-out documents without•

displaying a warning. 

General tab of the Preferences dialog box.

The Connection Settings tab
The Connection Settings tab of the Preferences dialog box allows you to specify

the connection settings for Quark Publishing Platform. To specify connection
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settings:

The Connection Settings tab of the Preferences dialog box

Enter the Quark Publishing Platform server’s IP address or name and port•

number in the Server Name fields.

The Protocol controls let you choose whether to use HTTP or HTTPS for•

communication with Quark Publishing Platform server. 

If you’re not sure which setting to use, ask your Quark Publishing Platform
administrator

You can choose to automatically log on with your current user credentials,•

or you can choose to provide your log on credentials by specifying a user

name and password.

The values in the User Name and Password field are defined for each user•

by the Quark Publishing Platform administrator. For Quark Publishing

Platform sites that use Lightweight Directory Application Protocol (LDAP) to

manage user lists, Quark Publishing Platform users log on with their

network user names and passwords. Log on passwords may or may not be

case-sensitive, depending on the Quark Publishing Platform administrator’s

specifications. These values can also be saved by specifying a name for them

in the Name field.
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The Search tab
The Search tab of the Preferences dialog box enables you to specify the search

settings and to control how revision comments are displayed.

The Search tab of the Preferences dialog box

The Search Options allows you to specify what to search for. The drop-down menu

displays the following options:

Name•

Content•

Name and Content•

Revision Comments allows you to specify when to display revision comments.

The drop-down menu displays the following options:

Always•

Never•

New Assignments Only•
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Working with the Platform
repository

Creating a new document from a repository template

You can create new documents from an existing repository template. 

You can create documents from “templates” that contain the minimum required

elements and attributes for a given document type. Documents may also contain

custom guidance text or instructions.

Choose File > New Document from Server1.

In the Available Templates menu, choose New Document from Server2.

Template.

The Select Template dialog displays.

Navigate to the repository folder that contains the desired template. Or, in3.

the dialog box, use the Quick Search feature to locate the desired document.

To use the Quick Search feature, type a search term in the box in the•

upper right corner of the Open from Server dialog box.
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The search results are displayed.

You can choose to view the results in either list view or snippet view. The
Quark Publishing Platform server manages version control for checked-in

documents. The revision history of an asset can be viewed and an older version can

be opened by selecting the asset and clicking View Revisions.

Select the template.4.

Click OK.5.

To create a new document:

The document is created and is ready for authoring. When you are finished

authoring, save the document to the repository.

Creating a new document from an existing document

You can create new documents from existing documents available in the Platform

server repository.

To create a new document:

Choose File > New Document from Server.1
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In the Available Templates menu, choose New Document from Existing2
Document.

The Select Document dialog displays.

Navigate to the repository folder that contains the desired document. Or, in the3
dialog box, use the Quick Search feature to locate the desired document.

To use the Quick Search feature, type a search term in the box in the upper•

right corner of the Open from Server dialog box.

The search results are displayed.

You can choose to view the assets in either list view or snippet view. The
Quark Publishing Platform Server manages version control for checked-in

documents. The revision history of an asset can be viewed and an older version can

be opened by selecting the asset and clicking View Revisions.

Select the document.4

Click OK.5

The document is created and is ready for authoring. When you are finished

authoring, save the document to the repository.
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Opening a repository document for viewing

You can open repository documents from any Office application that has the

adapter installed.

To open a document for viewing:

Choose File > Open from Server1.

In the Open from Server dialog box, navigate to the repository folder that2.

contains the desired document.

Or, in the dialog box, use the search feature to locate the desired document. 

To use the Quick Search feature, type a search term in the box in the•

upper right corner of the Open from Server dialog box.

To use an existing search, the Searches folder displays all Saved and•

Shared Searches stored at the repository. Select the desired search.

You can choose to view the results in either list view or snippet view. The
Quark Publishing Platform server manages version control for checked-in

documents. The revision history of an asset can be viewed and an older version can

be opened by selecting the asset and clicking View Revisions. Earlier versions

may only be opened read-only.

Select the document.3.

Click Open as Read Only.4.

The document displays, ready for viewing. The view in your repository software and

the Open from Server dialog show the file without the checked out icon. The

Checked Out by field remains cleared.

Checking out a document

You can check out and edit documents that are opened for viewing.
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The document must already be open in read-only mode in the Office application.

If the currently open document is not the latest version, it will be closed. The latest

version will be opened and checked out.

To check out an open document:

Choose File > Edit.•

The document is checked out and ready for editing.

You can also check out and edit documents from the Platform server.

Choose File > Open from Server1.

The Open from Server dialog displays.

Navigate to the repository folder that contains the desired document. Or, in2.

the dialog box, use the quick search feature to locate the desired document. 

Select the desired document and click Open.3.

The document is checked out and ready for editing.

The view in your repository software and the Open from Server dialog show the file

with the checked out icon.

The Checked Out by field is set to your User Name.

When you are finished authoring, save the document to the repository. 
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Saving document revisions

You can save and check in a document from the Office application it is open in.

Components within the document will be available for referencing by other

documents. For new documents, specify the desired repository folder and filename.

You can choose to check in and close the document or keep it checked out and

open for further editing.

To save a revision of a document:

Perform one of the following:1

To keep the document open: Choose File > Info > Save Revision to Server.•

To close documents: Choose File > Info > Save to Server & Close.•

The Save dialog box displays. The dialog box displays repository-related

information about the document you are saving.

You are not allowed to change the collection that the document is located in when
you are saving a revision. This can only be done when you are doing a Save/Close of

a document.

If you do not need the Repository View it can be collapsed. This is useful if a Form2
view displays which can make the vertical length of the dialog extend beyond the
screen.

Specify whether to check the file in as a Major Version or Minor Version.3

Click More Options and modify any other available attribute fields as appropriate.4

For new documents, choose a content type from the Content Type drop-•

down menu.

From the Workflow drop-down menu, choose which workflow should be•

applied to the document.
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In Status, choose the status which should be applied to the document based•

on your established processes.

To send the asset to a particular user or group or to No One, choose an•

option from the Routed To drop-down menu.

If your workflow relies on automatic status-based routing, the Routed To drop-
down menu value might change automatically when you choose an option from

the Status drop-down menu.

In Revision Comments, explain what was changed in the document.•

These revision comments are shown when the document is opened for viewing or
editing.

If the dialog box includes a Form View, complete the additional fields.•

For new documents, specify the desired repository folder and filename.•

Click Save.•

The current version of the document is saved to the repository. If you chose to keep

the document open, the document status is checked out and the view in your

repository software and the Open dialog show the file with the checked out

icon.

If the document includes validation rules, these are evaluated when you attempt to
save the document. The system will notify you of any rules that have been violated.

For example, certain fields that are empty that must be completed.

When a document is checked in, any references to local images are converted to
server references. These images will be checked in first and then will be

related/referenced to the document on the server.

For further information on saving document revisions, setting attribute values and
workflows, see the Quark Publishing Platform Guide.

Discarding changes and check out

You can use the Discard Check Out feature to cancel the checkout of a document.

All authoring changes will be discarded.

The document must already be open in the application.

To discard check out:

Choose File > Info > Discard changes.1

The system prompts, Do you want to revert changes?. Click Yes.2

Changes made to the document since it was checked out are discarded and the

document is closed.

The view in your repository software and the Open from Server dialog show the file
without the checked out icon. The Checked Out By field is cleared. The document

status changes from checked out to checked in.
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Closing server documents

Documents checked out from the Quark Publishing Platform server need to be

saved to the server or saved and closed to preserve any changes made to them

locally. Closing the document via a keyboard shortcut, through the File menu or by

clicking on the Close icon on the top right hand corner of the window displays a

dialog with the following options: 

Save to Server and Close: Updates the Quark Publishing Platform server1.

with your most current changes, checks in and then closes the project or

template.

Discard Changes: Discards the checkout, closes the project or template and2.

makes it available for others to check out. An alert displays, allowing you to

save or discard any changes made since your checkout. If you saved a

revision on Quark Publishing Platform Server, it becomes the current version

when you cancel a checkout.

Close: Closes the document. If the document has not been saved, an alert3.

displays, allowing you to save the open document locally. If you choose

Don’t Save, the document is closed with the last saved change. Choosing

Cancel dismisses the alert.
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The Quark Publishing Platform User
Interface

Users can access their Quark Publishing Platform workflow through the Office®

adapters for Quark Publishing Platform. This chapter provides details of the Quark

Publishing Platform user interface available in PowerPoint, Word, Visio and Excel

on Microsoft Windows®. For more information about the Quark Publishing

Platform user interface, see A Guide to Quark Publishing Platform.

The Excel Adapter for Quark Publishing Platform

The Excel Adapter for Quark Publishing Platform allows users to create new

documents using a document or a template available on the server and check in and

check out files from the Platform repository.

Supported File Types

The Excel Adapter for Quark Publishing Platform currently supports the following

formats:

.xslx (Excel Workbook)•

.xltx (Excel Template)•

.xlsb (Excel Binary Workbook)•

.xlsm (Excel Macro-Enabled Workbook)•

Componentization in Microsoft Excel
Componentization in Microsoft Excel is aimed at editorial flows that may require

the source documents to be independent of exported components, yet retaining the

capability to update them.

Data in Microsoft Excel workbooks can be exported to multiple formats as

components. These components can be referenced directly in Quark XML Author,

Quark Author Web Edition and Microsoft PowerPoint.

Components can be exported from local Excel workbooks without checking in the

source documents to the Platform server, preserving the formatting and content of

the source document.

The formatting and content of ranges or charts exported as Microsoft Excel can be

altered, although a link to the original document is maintained. If the source

requires changes to its structure or content, all linked components can be updated.
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Any components that do not require to be linked to the source document can be

delinked.

Exporting Ranges from Microsoft Excel
Selected ranges in Microsoft Excel can be exported as various content types. To

export a selected range:

Select a range of cells.1.

Invoke the contextual menu and choose an option from Smart Content >2.

Export As >:

Excel Table: Ranges are exported as a new Excel workbook with all•

formatting information and values. Formulas and references are not

exported.

Smart Table: Exports ranges in the native Quark Author table format.•

Structured Table: Exports the selected range in the native Quark XML•

Author table format.

JPEG: Exports the selected range as an image (jpg).•

PDF: Exports the selected range as an image (pdf).•

PNG: Exports the selected range as an image (png).•

Exporting a range containing a formula or a link will only export its value.

Exporting a range again will change the contextual menu entry to Smart Content >
Export Again As

Local edits to the exported Excel table will be overwritten when the components are
exported again.

If the Selected range is not named, a dialog to set a name for the exported range will
be displayed.
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Enter a name for the range or use the suggested name. Set the scope of the3.

range. The scope of a range can be limited to the current sheet or made

available throughout the workbook. Click OK. The Save dialog displays. 

The Name drop-down list only displays ranges with scope set to the current sheet or
throughout the workbook.

Navigate to the required repository folder and click Save.4.

If a component with the same name exists in the destination, an alert with an
option to change the name of the asset displays. 

The selected range is saved to the server with the specified name.
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Exported components contain an attribute with information about the local path of
the file from which the component was exported. If changes are required in the

original file, the local file can be edited by choosing Edit Original from the

contextual menu in Quark XML Author.

Exporting Charts from Microsoft Excel
Charts in Microsoft Excel can be exported as various content types.

To export a chart:

Select the chart.1.

Invoke the contextual menu and choose Smart Content > Export As>2.

Choose one of the following options:

Excel Chart: Charts are exported as a new Excel workbook with all•

formatting information and values.

JPG: Exports the selected chart as an image (.jpg).•

PDF: Exports the selected chart as an image (.pdf).•

PNG: Exports the selected chart as an image (.png).•

Exporting a chart again will change the contextual menu entry to Smart Content >
Export Again As.

Enter a name for the chart or use the suggested name.3.

If a chart with the same name exists in the Excel document, an alert with an option

to change the name of the chart displays.
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The save process needs to be re-initiated once the name of the chart is changed. The

Save dialog displays. 

Navigate to the required repository folder and click Save.4.

If a component with the same name exists in the server, an alert with an option to
change the name of the component displays.

The component is saved to the server with the specified name.
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Copy to Server Clipboard
Tables and charts can be copied to the server clipboard from Microsoft Excel using

the Excel Adapter for Quark Publishing Platform. To copy an item from Excel,

select the desired chart or cells, and choose Copy to Server Clipboard from the

context menu.

Charts can also be copied to the server clipboard using the CTRL+SHIFT+C key
combination. 

The selected item is copied to the server clipboard and is available for pasting using

the Paste from Server option available in all instances of Microsoft PowerPoint,

Quark Author and Quark XML Author for Microsoft Word that are currently

connected to the server with the same credentials. 

No link to the server is maintained with tables pasted from the server clipboard.

Clipboard links are maintained in the Excel document for charts copied to the
server clipboard. These are converted to asset links once clipboard data is saved to

the server in Quark Author. 

Push Updates
The Push Updates button in the ribbon updates changes made to all linked

components exported from Microsoft Excel to the Quark Publishing Platform server.

These updates occur silently. No input is required from the user after clicking the

Push Updates button. 

Once the update process is complete, the Smart Content pane is automatically

refreshed and displays the updated versions of the components.

The Smart Content Pane in Microsoft Excel

The Smart Content Pane is available for all supported Microsoft Office applications,

however, the contextual menu options offered by the Smart Content Pane may

differ across these applications. The Smart Content pane in Microsoft Excel lists the

components that have been exported from the currently open document. To

show/hide the Smart Content pane, click the Smart Content Pane button in the

Home ribbon. 
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The following operations can be performed on the components listed in the Smart

Content Pane:

Go To: Selects the exported range on the worksheet.•

Update Component: Saves a revision of the component to the Platform•

server that includes any changes made to the component.

Edit Component: Opens the selected component for editing in Microsoft•

Excel. The component will be updated once checked in to the server.

This option is only available for Microsoft Excel components.

Break Component Link: Breaks the link between the exported component•

and the document the range was exported from.

Link Component to Selected Range: Choosing this option displays a•

dialog.

Choosing Link from the dialog links the exported component to currently selected

range other than the originally exported range. If no name has been specified for

the range, a name must be set for the new range. The components of the range need

to be updated by invoking the contextual menu from the worksheet or from the

Smart Content pane. Selecting Link & Update links the exported component to the

currently selected range and updates the selected component in one step.

View Revisions: Displays a list of revisions a component has undergone.•

Where Used: Displays a list of documents where this component has been•

referred.

Properties: Displays the attributes of the components from the server.•

Preview: Displays a preview of the selected component. Multiple preview•

channels can be configured.

The PowerPoint Adapter for Quark Publishing Platform

The PowerPoint Adapter for Quark Publishing Platform allows users to manage,

reuse and create new presentations using slides, Excel tables, Excel charts, audio,
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video and images available on the server and check in and check out files from the

Platform repository. Users can easily update slide decks and reference components

as needed, all while maintaining familiar PowerPoint features for editing and

design. 

Supported File Types

The PowerPoint Adapter for Quark Publishing Platform currently supports the

following formats:

.pptx (PowerPoint Presentations)•

.potx (PowerPoint Templates)•

.pptm (Macro enabled PowerPoint Presentations)•

.potm (Macro enabled PowerPoint Templates)•

Slides from checked-in documents will be available for referencing in Microsoft

PowerPoint, Quark XML Author or Quark Author.

PowerPoint Slide assembly
PowerPoint users can easily assemble slides by reusing slides or complete

PowerPoint decks from the Server. Users can also easily update slide decks and

reference components as needed from the Quark Publishing Platform Server, all

while maintaining familiar PowerPoint features for editing and design.

Inserting slides
Slides checked in to the Quark Publishing Platform Server can be inserted into a

PowerPoint presentation. To insert slides from the Platform server:

Choose Reuse Slides from Server from the Platform ribbon or from the contextual1
menu. The Reuse Slides from Server dialog displays.

Browse to the required slide and click OK.2
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Previous versions of the selected asset can also be chosen using the View Revisions

button.

The path to slide is updated in Insert slides from and the available slides are

populated in the Reuse Slides from Server pane.

Select the slides that you wish to insert and choose Insert Slide(s). Choose Insert3
Deck to insert the entire slide deck.

The File Save dialog displays if the PowerPoint presentation has not been saved.
Click Save to save the file to your computer.

If the Keep source formatting checkbox is deselected, the existing formatting of
the slides will be overridden and the formatting of the current PowerPoint

presentation will be applied to them.

If the Link to server checkbox is deselected, this document cannot be updated to
the latest version available on the server.

The slides are added to the PowerPoint document.

Component references
In addition to existing slides and PowerPoint decks, server components such as

Excel tables, Excel charts, audio, video and images can also be easily added to slides. 

Picture from Server
Pictures checked into the platform server can easily be added to enrich PowerPoint

slides. To insert a picture into a PowerPoint Slide: 
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Click the Picture from Server button in the Platform1
ribbon.

Browse to the desired picture in the Insert dialog.2

Previous versions of the selected asset can also be chosen using the View Revisions

button.

Click OK.3

The inserted picture can be replaced with another picture from server by selecting
Change Picture from the contextual menu.

The selected picture is inserted into the PowerPoint slide.

Table from Server
Microsoft Excel Tables that have been exported using the Excel Adapter for Quark

Publishing Platform and Excel documents checked into the server can be inserted

into slides using the Table from Server button in the Platform ribbon. To insert an

Excel Table or Excel document:

Click the Table from Server button in the Platform ribbon.1
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Browse to the desired table or spreadsheet from the Insert dialog.2

Previous versions of the selected asset can also be chosen using the View Revisions

button.

Click OK.3

If the selected document is a Microsoft Excel Table, the table will be inserted
immediately.

If the selected document is a Microsoft Excel document, the Insert Table dialog
displays.

Browse to the desired table location, choose a sheet from the drop-down menu and4
select a range from the drop-down menu, or type in a custom range. Click the
Preview button to see a preview of the selected table or range and click OK to insert
the table. 

The inserted table can be replaced by another table from server by selecting Change
Link from the contextual menu.

The selected table is inserted.

Chart from server
Microsoft Excel Charts can be added to slides as an editable object or as a shape. No

content modification or range selection is possible when charts are added as a

shape. 
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The following types of charts can be added to slides:

Microsoft Excel Chart as Shape - The chart is added to the slide as a•

graphic. Content modification is not permitted.

Microsoft Excel Chart - Content modification and range selection is•

permitted. Displayed data in these charts can be modified.

Inserting Microsoft Excel charts
Microsoft Excel Charts can be added to slides as editable objects. The design,

formatting and data values of the chart can be edited within Microsoft PowerPoint. 

To insert a Microsoft Excel Chart:

Choose Chart from Server > Microsoft Excel Chart from the Platform1.

ribbon.

Browse to the desired Chart in the Insert dialog.2.

Click OK. If the selected Chart is a Microsoft Excel document, the Insert3.

Chart dialog displays.
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Choose the desired sheet and chart and click the Preview button to see a4.

preview of the selected chart and click OK to insert the chart. 

The selected Chart is inserted. These charts can be edited akin to native PowerPoint
Charts. 

Customizing charts in a PowerPoint document

Clicking the icon opens the Chart Elements flyout menu. Items from the

menu can be selected or deselected.

Clicking the icon opens the Style and Color flyout menu. The styling and

color scheme of the chart can be altered from this menu. 
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Clicking the icon opens the Values and Names flyout menu.

Inserting Microsoft Excel Chart as Shape
Charts checked in the Platform server can easily be added to PowerPoint slides as a

shape. To add a Microsoft Excel Chart as a shape:

Choose Chart from Server > Microsoft Excel Chart as Shape from the Platform1
ribbon.
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Browse to the desired Chart in the Insert dialog.2

Previous versions of the selected asset can also be chosen using the View Revisions

button.

Click OK. If the selected table is a Microsoft Excel document, the Insert Chart3
dialog displays.

Select the desired sheet and Chart and click the Preview button to see a preview of4
the selected chart. Click OK to insert the chart.

The selected Chart is inserted.

Charts inserted as a shape cannot be edited.

The inserted chart can be replaced by another chart from server by selecting
Change Link from the contextual menu.

Paste from Server
Tables and charts can be copied from Microsoft Excel using the Excel Adapter for

Quark Publishing Platform. The Quark Publishing Platform Server facilitates

pasting the copied items in PowerPoint, Quark Author and Quark XML Author.
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The copied items can be pasted using the Paste from Server button. Copied Excel

tables will be pasted as native PowerPoint shapes and copied charts as native

PowerPoint charts (as long as the logged on user is the same).

A link to the server is not maintained with components pasted from the server
clipboard.

Video from Server
Video files checked into the platform server can easily be added to enrich

PowerPoint slides. To insert a video into a PowerPoint Slide: 

Click the Video from Server button in the Platform ribbon.1

Browse to the desired video in the Insert dialog.2

Previous versions of the selected asset can also be chosen using the View Revisions

button.

Click OK. The selected video is inserted into the PowerPoint slide.3

Only server images can be used as poster images for Server videos.

You can add a poster image for the inserted video clip. To insert a poster image,
choose Change Poster Image from the contextual menu or click Format > Poster

Frame > Image from File.

The inserted video can be replaced with another video from server by selecting
Change Link from the contextual menu.

Audio from server
Audio files checked into the platform server can easily be added to enrich

PowerPoint slides. To insert an audio clip: 
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Click the Audio from server button in the Platform ribbon.1

Browse to the desired audio clip in the Insert dialog.2

Previous versions of the selected asset can also be chosen using the View Revisions

button.

Click OK. The selected audio is inserted into the PowerPoint slide.3

You can add a cover image for the inserted audio clip. To insert a cover image,
choose Change Picture from the contextual menu or select Format >Change

Picture.

Only server images can be used as cover images for server audio clips.

The inserted audio clip can be replaced with another audio clip from server by
selecting Change Link from the contextual menu.

The Smart Content Pane in Microsoft PowerPoint
The Smart Content pane is available in Microsoft Excel and PowerPoint, however,

the contextual menu options offered by the Smart Content pane may differ across

these applications. 

In Microsoft PowerPoint, the Smart Content Pane lists the components referred

from the Quark Publishing Platform server. To show/hide the Smart Content pane,

click the Smart Content Pane button in the Home or the Platform ribbon. 
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Changes and updates to referred components are indicated with the indicator

in the Smart Content pane in Microsoft PowerPoint.

Updates to any referred components are also indicated in the Smart Content pane

icon. 

Invoking the contextual menu here provides the option to update the asset to the

latest version available on the server. The metadata of the latest version will always

be shown in the Smart Content Pane. If the inserted asset has been checked out

from the server, the checked out icon will be displayed in the right hand

corner. The Smart Content pane in Microsoft PowerPoint allows the following

operations to be performed on the listed components via the contextual menu:

Go to: Moves the focus to the selected reference on the canvas.•

Update Link: The element reference is refreshed. Local changes will be•

replaced with the latest content on the server.

Break Link: The link to the server asset is removed. Any changes made to•

the asset on the server will not be reflected in the client.

Edit Original: Opens the original Excel document from which the referred•

table, picture or chart has been exported for editing.

Edit Link: The referred table, chart or PowerPoint slide is checked out to be•

edited.

Open Link: Opens a read-only copy of the asset the element is referred•

from.

View Revisions: Displays a list of revisions a component has undergone.•

Where Used: Displays a list of documents where this component has been•

referred.

Properties: Displays the attributes of the components from the server.•

Preview: Displays a preview of the selected component. Multiple preview•

channels can be configured.

The Preview Pane
The Preview pane displays a preview of the current PowerPoint presentation. To

show/hide the Preview pane, click Preview Pane in the Home ribbon. 
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Multiple preview channels can be configured in the Preview Pane. The currently

supported channels are HTML5 and PDF.

Previews can be downloaded in the selected preview format by clicking the

button. 

The Save dialog displays if the PowerPoint presentation has not been saved. Choose
Save to Save the file to your computer.

Multi-channel Publishing
The PowerPoint Adapter for Quark Publishing Platform Server facilitates the

publishing of a PowerPoint slide deck to various formats.

Slides can be published as PDF, Responsive HTML 5 or PPSX.

Publish as PDF•
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Publishing slides as PDF creates a PDF of the entire slide deck. All server references

are resolved prior to publishing the slides.

Publish as Responsive HTML5•

Publishing slides as Responsive HTML5 creates an HTML rendition of the entire

slide deck. All server references are resolved prior to publishing the slides.

Publish as PPSX•

Publishing slides as PPSX creates a PowerPoint slideshow of the entire slide deck. All

server references are resolved prior to publishing the slides.

To export a presentation in one of the available formats: 

Click File > Export > Publish.1.

Choose the desired publishing format.2.

Select the output location from the Publishing Settings dialog and click OK3.

to publish the slide deck.

The slide deck is published to the desired format.

The Word Adapter for Quark Publishing Platform

The Word Adapter for Quark Publishing Platform allows users to create new

documents using a document or a template available on the server and check in and

check out files from the Platform repository.

Supported File Types

The Word Adapter for Quark Publishing Platform currently supports the following

formats:

.docx (Word Document)•

.dotx (Word Template)•

Component referencing is currently not supported for Microsoft Word documents.
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The Visio Adapter for Quark Publishing Platform

The Visio Adapter for Quark Publishing Platform allows users to create new

documents using a document or a template available on the server and check in and

check out files from the Platform repository.

Supported File Types

The Visio Adapter for Quark Publishing Platform currently supports the following

formats:

.vsdx (Visio Drawing)•

.vstx (Visio Template)•

.vsdm (Visio Macro-Enabled Drawing)•

.vstm (Visio Macro-Enabled Template)•

Checked-in Visio drawings from these documents will be available for referencing in

Quark XML Author or Quark Author.
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Contacting Quark

The support portal allows you to log support tickets, track tickets, receive status

notifications, chat with a technical support representative, search the Knowledge

Base, and access product documentation.

With direct access to documentation across all Quark software - from QuarkXPress

and App Studio to Quark Enterprise Solutions - you can find answers to your

questions at your convenience. Our support team is also available to help, either

through our support portal, or via phone for our maintenance contract customers.

If you are a Quark customer and have a current maintenance or support contract

your account has already been created for you using your registered email address. If

you do not have a support contract you can purchase a single support incident to

get your problem resolved. If you have purchased or registered a supported product,

you are eligible for free support for the first 90 days.

In the Americas

For more details, please check out our support website

Outside the Americas

For countries outside the Americas, please visit the following sites to access your

support account:

Support Website

France - www.quark.com/fr/support•

Germany - www.quark.com/de/support•

http://www.quark.com/fr/support/
http://www.quark.com/de/support/
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Legal notices

©2022 Quark Software Inc. and its licensors. All rights reserved.

Protected by the following United States Patents: 5,541,991; 5,907,704; 6,005,560; 

6,052,514; 6,081,262; 6,633,666 B2; 6,947,959 B1; 6,940,518 B2; 7,116,843; 

7,463,793; and other patents pending.

Quark, the Quark logo, and Quark XML Author are trademarks or registered 

trademarks of Quark Software Inc. and its affiliates in the U.S. and/or other 

countries. All other marks are the property of their respective owners.
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